(hide navigation)
  • Swedish content
Fund my projects
Don't miss
Page thumbnail
Log in
Latest comments
RSS feed
Hardware projects

Beagleboard stable USB EHCI hack

Occasionally, the USB EHCI controller on a Rev C3 Beagleboard stops working until the system is rebooted. It is usually triggered by heavy traffic, e.g. due to a WLAN dongle or a USB thumbdrive. It was apparently fixed properly in Rev C4, but if you're stuck with a C3 board the following hack may solve the problem for you.

The error is due to noise on the VDD2 power rail (1.8 V). Too many events occuring simultaneously may cause the power rail to dip, which in turn causes the USB PHY to panic. One way to lower the probability of this is to increase the capacitance of the power rail near the USB PHY.

As you can see in the picture, I've soldered a 10 uF electrolytic capacitor across C97, thus increasing the capacitance from 10 uF to 20 uF. The capacitor is oriented with the positive side towards the SD card slot, but you may want to verify this yourself using a voltmeter on a running system.

Be careful, and don't blame me if you mess it up. But if you do, you now have a valid reason to buy a Rev C4 board. =)

The capacitance hack was suggested in this usenet thread, along with much other speculation.

Posted Thursday 13-May-2010 15:35

Discuss this page

Disclaimer: I am not responsible for what people (other than myself) write in the forums. Please report any abuse, such as insults, slander, spam and illegal material, and I will take appropriate actions. Don't feed the trolls.

Jag tar inget ansvar för det som skrivs i forumet, förutom mina egna inlägg. Vänligen rapportera alla inlägg som bryter mot reglerna, så ska jag se vad jag kan göra. Som regelbrott räknas till exempel förolämpningar, förtal, spam och olagligt material. Mata inte trålarna.

Wed 22-Sep-2010 21:56
Thank you very much for posting the hack!
I found a tantalum capacitor on a broken wireless card and put it over C97, with a capacitance slightly bigger than the 10uF you proposed (22uF) - my USB interfaces work like a charm now! No more unexpected disconnects!
André van Schoubroeck
Mon 21-Mar-2011 13:41
Thank you, I will need to try this.
The USB problems is what kept me from using the BeagleBoard before.
(And I assumed it was kernel-related as some sites suggested this)
Sat 10-Sep-2011 18:41
Thanks, worked for me :)
Tue 10-Apr-2012 10:21
Question - do you think this hack would also work for the Beagleboard xM rev. C? It seems to be having the same issue and schematics have that part of the Beagleboard c3 as the same as the Beagleboard xM rev. C with the 10 uF capacitor on v1_8. Except on the Beagleboard xM its C136. Going to try this tomorrow
Sun 13-May-2012 19:32
USB Beagleboard xM fails as well
Tue 16-Apr-2013 00:17
Question - do you think this hack would also work for the Beagleboard xM rev. C? [...] Going to try this tomorrow

Please, tell us. Did it work?
Sat 14-Sep-2013 11:26
Question - do you think this hack would also work for the Beagleboard xM rev. C? [...] Going to try this tomorrow

Please, tell us. Did it work?

I think hardware hacking are useless to XM at all (we tried that before)

My workplace got a dozen of beagleboard XM (same batch, same version)
some of them are 'quite normally',which can survive during our test.
test by copy 10GB+ data via the eth interface to the usb pendrive mount on USB of beagleboard-XM
some of them will be dumb after 100MB~2GB data copy

I guess the problem may be was the defect of the chip(EHCI?)

Test environment was totally same
same SDcard, same OS, same pendrive, same data, same network, same command.