Forum comments in chronological order

Disclaimer: I am not responsible for what people (other than myself) write in the forums. Please report any abuse, such as insults, slander, spam and illegal material, and I will take appropriate actions. Don't feed the trolls.

Jag tar inget ansvar för det som skrivs i forumet, förutom mina egna inlägg. Vänligen rapportera alla inlägg som bryter mot reglerna, så ska jag se vad jag kan göra. Som regelbrott räknas till exempel förolämpningar, förtal, spam och olagligt material. Mata inte trålarna.

Jun 2010

Turbulence

Anonymous
Wed 2-Jun-2010 19:45
Congratulation, at work, available here.
What would be best choice for a VGA terminal (80 col x 50 row), Atmega or Propeller?

Fausto Oliveira / Brazil
lft
Linus Åkesson
Wed 2-Jun-2010 22:27
Congratulation, at work, available here.
What would be best choice for a VGA terminal (80 col x 50 row), Atmega or Propeller?

Fausto Oliveira / Brazil

Definitely the propeller. You'd have to store 80 x 50 random characters along with colour information, for a total of 8000 bytes of RAM.

The hardware chiptune project

Anonymous
Wed 2-Jun-2010 22:52
Hi, I've started to experiment a bit with avr's.
Just tried to build the Hardware Chiptune and flashed the atmega88 with the hexfile containing the tune.
My only problem is that some pins from the PortD just contain a signal sounding like fast random notes in the range of 10khz and above. Maybe it's a faulty atmega88 now caused by an accidental short between the input of the 7805 and PD7? Anyway I will get another atmega88 within the next few days to try out :)

Keep up your fantastic work!

Phasor

Anonymous
Thu 3-Jun-2010 02:19
Hi Linus,
I rebuilt your Phasor circuit, and recorded it's output into a very nice mpeg file. I'd like to send it to you, so please remove my E-mail address (*@freemail.hu) from your spam list.
Regards, Zoli

The hardware chiptune project

Anonymous
Fri 4-Jun-2010 16:25
I tried it with another Atmega88 but with the same result.
lft
Linus Åkesson
Sun 6-Jun-2010 15:37
My only problem is that some pins from the PortD just contain a signal sounding like fast random notes in the range of 10khz and above.

This sounds like a hardware problem, such as an accidental short between signals. It's also possible that it's caused by interference from a nearby AC signal, although if you're using a 7805 I don't see where the interference would come from. Also, if there's a break somewhere in the DAC ladder (e.g. faulty connection to ground), it could start to behave as an antenna and pick up interference.

Phasor

lft
Linus Åkesson
Sun 6-Jun-2010 15:43
Hi Linus,
I rebuilt your Phasor circuit, and recorded it's output into a very nice mpeg file. I'd like to send it to you, so please remove my E-mail address (*@freemail.hu) from your spam list.
Regards, Zoli

Please try this address instead: linuslft@gmail.com
Anonymous
Tue 8-Jun-2010 18:05

lft wrote:

Hi Linus,
I rebuilt your Phasor circuit, and recorded it's output into a very nice mpeg file. I'd like to send it to you, so please remove my E-mail address (*@freemail.hu) from your spam list.
Regards, Zoli

Please try this address instead: linuslft@gmail.com

I sent a link via dropbox, please open that letter.

The hardware chiptune project

Anonymous
Tue 8-Jun-2010 19:32

lft wrote:

This sounds like a hardware problem, such as an accidental short between signals. It's also possible that it's caused by interference from a nearby AC signal, although if you're using a 7805 I don't see where the interference would come from. Also, if there's a break somewhere in the DAC ladder (e.g. faulty connection to ground), it could start to behave as an antenna and pick up interference.

I solved the problem, the resistor ladder I used was no R-2R one, now it works as ecpected :)

Craft

Anonymous
Sun 13-Jun-2010 05:09
Could you please make a parts list? I know the schematics include all parts, but still, it would make it easier to acquire all components.

The remote control project

Anonymous
Tue 15-Jun-2010 18:05
i like your project and i am waiting for your source code.so plz send as soon as possible......@ vigneshrockz1992@yahoo.com

Blåsyra

Anonymous
Wed 16-Jun-2010 17:04
Har Linus Åkesson läst om amygdalin, laetril och vitamin B17? Jag kan föreslå G Edward Griffins bok "World without cancer" från 1974. Det finns en hel del kliniker, bl a i Tyskland och Mexico, som behandlar cancerpatienter intravenöst med laetril. Ren cyanid i gasform är nåt helt annat än bundet i naturliga molekyler. Cyanid och benzaldehyd frigörs från laetrilmolekylen endast vid kontakt med cancerceller och förgiftar dessa - de dör. Eftersom man inte kan ta patent på en naturlig produkt har denna kunskap smutskastats som kvacksalveri av "Big Pharma".

För övrigt består även vitamin B12 av en cyanidförening men den är det visst ingen som vill skrämmas med.

Hälsningar, Anders

Craft

Anonymous
Thu 17-Jun-2010 22:14
Hi, i have a little problem here with craft. some colours doesn't seem to be the correct ones, cyan is missing in the plasma (showing another shade of blue instead) or the first tunnel isn't coloured red and white (it's purple and violet) for an example. any idea? i checked the hardware a few times and it looks ok.
lft
Linus Åkesson
Tue 22-Jun-2010 19:29
Hi, i have a little problem here with craft. some colours doesn't seem to be the correct ones, cyan is missing in the plasma (showing another shade of blue instead) or the first tunnel isn't coloured red and white (it's purple and violet) for an example. any idea? i checked the hardware a few times and it looks ok.

Did you connect AVcc? In the original design, AVcc was left floating (by mistake), and this probably affects the amount of current that can be sourced from PORTC. Otherwise I really don't know.

Phasor

Anonymous
Wed 23-Jun-2010 23:16
Great Job again linus!
I really aspire to reach a level you are at.

If I make eagle schematic files of this like last time will your consider posting them?

Craft

Anonymous
Fri 25-Jun-2010 13:21

lft wrote:

Did you connect AVcc? In the original design, AVcc was left floating (by mistake), and this probably affects the amount of current that can be sourced from PORTC. Otherwise I really don't know.

At first I also connected the AVcc Pin, but then I disconnected it again since I found out that there's something wrong with the colours and I thought it could have something to do with AVcc but disconnecting it didn't change anything.

Anyway I also don't know what's the Problem here but I let you know what's wrong when I get it solved.

Phasor

Anonymous
Sat 26-Jun-2010 00:42
Amazing! I cannot believe how that much video and audio can be created with 8.5kB worth of program. Or how the AVR can render some of those graphics. It's brilliant!